Skip to content

← Actionable
High, CVSS 7.5amended

Uncontrolled Resource Consumption in asyncua and opcua

CVE-2022-25304GHSA-mfpj-3qhm-976m

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI opcua

    Affected
    <= 0.98.13
    Fixed in
    no fixed version recorded
  • PyPI asyncua

    Affected
    <= 0.9.95
    Fixed in
    0.9.96

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-25304: 1.37% estimated exploitation activity in the next 30 days; percentile 72.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All versions of package opcua; all versions of package asyncua are vulnerable to Denial of Service (DoS) due to a missing limitation on the number of received chunks - per single session or in total for all concurrent sessions. An attacker can exploit this vulnerability by sending an unlimited number of huge chunks (e.g. 2GB each) without sending the Final closing chunk.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mfpj-3qhm-976m

  2. Revision 1 · created ·

    Published from osv record GHSA-mfpj-3qhm-976m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25304

Advisory: Uncontrolled Resource Consumption in asyncua and opcua
IDs: CVE-2022-25304, GHSA-mfpj-3qhm-976m
Record: https://patchnext.com/advisories/cve-2022-25304 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: asyncua 0.9.96. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI opcua: affected <= 0.98.13
- PyPI asyncua: affected <= 0.9.95; fixed in 0.9.96

## Suggested inspection (read-only)
- `python -m pip show opcua`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show asyncua`: prints the installed version. Run with the environment that serves production active.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on opcua, asyncua.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfpj-3qhm-976m (OSV record GHSA-mfpj-3qhm-976m lists affected ranges: PyPI asyncua >=0 =0 <=0.98.13)
- Verified: https://github.com/advisories/GHSA-mfpj-3qhm-976m (GitHub-reviewed advisory GHSA-mfpj-3qhm-976m lists affected ranges: PyPI asyncua >=0 =0 <=0.98.13)

Commands are suggestions: review each one before running it.

Loading voting…