Whoogle Search Cross-site Scripting via string parameter
CVE-2022-25303GHSA-mxvc-fwgx-j778
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (whoogle-search 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI whoogle-search
- Affected
- < 0.7.2
- Fixed in
- 0.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mxvc-fwgx-j778 lists affected ranges: PyPI whoogle-search >=0 <0.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mxvc-fwgx-j778 lists affected ranges: PyPI whoogle-search >=0 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2022-25303: 0.97% estimated exploitation activity in the next 30 days; percentile 61.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package whoogle-search before version 0.7.2 is vulnerable to Cross-site Scripting (XSS) via the query string parameter q. In the case where it does not contain the http string, it is used to build the errormessage that is then rendered in the error.html template, using the flask.rendertemplate function. However, the errormessage is rendered using the | safe filter, meaning the user input is not escaped.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mxvc-fwgx-j778
- Revision 1 · created ·
Published from osv record GHSA-mxvc-fwgx-j778
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25303 Advisory: Whoogle Search Cross-site Scripting via string parameter IDs: CVE-2022-25303, GHSA-mxvc-fwgx-j778 Record: https://patchnext.com/advisories/cve-2022-25303 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: whoogle-search 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI whoogle-search: affected < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - `python -m pip show whoogle-search`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on whoogle-search. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mxvc-fwgx-j778 (OSV record GHSA-mxvc-fwgx-j778 lists affected ranges: PyPI whoogle-search >=0 <0.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mxvc-fwgx-j778 (GitHub-reviewed advisory GHSA-mxvc-fwgx-j778 lists affected ranges: PyPI whoogle-search >=0 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…