Skip to content

← Actionable
High, CVSS 7.5

Drupal core Information Disclosure vulnerability

CVE-2022-25275GHSA-xh3v-6f9j-wxw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.4.3, 9.3.19, 7.91), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 7.0.0, < 7.91>= 8.0.0, < 9.3.19>= 9.4.0, < 9.4.3
    Fixed in
    9.4.3, 9.3.19, 7.91

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-25275: 0.67% estimated exploitation activity in the next 30 days; percentile 51.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In some situations, the Image module does not correctly check access to image files not stored in the standard public files directory when generating derivative images using the image styles system. Access to a non-public file is checked only if it is stored in the "private" file system. However, some contributed modules provide additional file systems, or schemes, which may lead to this vulnerability. This vulnerability is mitigated by the fact that it only applies when the site sets (Drupal 9) $config['image.settings']['allowinsecurederivatives'] or (Drupal 7) $conf['imageallowinsecurederivatives'] to TRUE. The recommended and default setting is FALSE, and Drupal core does not provide a way to change that in the admin UI. Some sites may require configuration changes following this security release. Review the release notes for your Drupal version if you have issues accessing files or image styles after updating.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xh3v-6f9j-wxw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25275

Advisory: Drupal core Information Disclosure vulnerability
IDs: CVE-2022-25275, GHSA-xh3v-6f9j-wxw3
Record: https://patchnext.com/advisories/cve-2022-25275 (revision 1, source checked 26 Oct 2026, 14:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.4.3, 9.3.19, 7.91. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 7.0.0, < 7.91; >= 8.0.0, < 9.3.19; >= 9.4.0, < 9.4.3; fixed in 9.4.3, 9.3.19, 7.91

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xh3v-6f9j-wxw3 (GitHub-reviewed advisory GHSA-xh3v-6f9j-wxw3 lists affected ranges: Packagist drupal/core >=7.0.0 =8.0.0 =9.4.0 <9.4.3)

Commands are suggestions: review each one before running it.

Loading voting…