Skip to content

← Actionable
High, CVSS 7.5

Improper input validation in Drupal core

CVE-2022-25271GHSA-fmfv-x8mp-5767

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 9.3.6, 9.2.13, 7.88), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 9.3.0, < 9.3.6>= 8.0.0, < 9.2.13>= 7.0.0, < 7.88
    Fixed in
    9.2.13, 7.88, 9.3.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2022-25271: 1.27% estimated exploitation activity in the next 30 days; percentile 69.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal core's form API has a vulnerability where certain contributed or custom modules' forms may be vulnerable to improper input validation. This could allow an attacker to inject disallowed values or overwrite data. Affected forms are uncommon, but in certain cases an attacker could alter critical or sensitive data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fmfv-x8mp-5767

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25271

Advisory: Improper input validation in Drupal core
IDs: CVE-2022-25271, GHSA-fmfv-x8mp-5767
Record: https://patchnext.com/advisories/cve-2022-25271 (revision 1, source checked 26 Oct 2026, 14:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 9.3.6, 9.2.13, 7.88. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 9.3.0, < 9.3.6; >= 8.0.0, < 9.2.13; >= 7.0.0, < 7.88; fixed in 9.2.13, 7.88, 9.3.6

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fmfv-x8mp-5767 (GitHub-reviewed advisory GHSA-fmfv-x8mp-5767 lists affected ranges: Packagist drupal/core >=9.3.0 =8.0.0 =7.0.0 <7.88)

Commands are suggestions: review each one before running it.

Loading voting…