Missing permission check in Jenkins Conjur Secrets Plugin allows enumerating credentials IDs
CVE-2022-25190GHSA-372f-jc47-7gr5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.conjur.jenkins:conjur-credentials 1.0.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.conjur.jenkins:conjur-credentials
- Affected
- < 1.0.12
- Fixed in
- 1.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-372f-jc47-7gr5 lists affected ranges: Maven org.conjur.jenkins:conjur-credentials >=0 <1.0.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2022-25190: 0.68% estimated exploitation activity in the next 30 days; percentile 52.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Conjur Secrets Plugin 1.0.11 and earlier does not perform a permission check in an HTTP endpoint. This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-372f-jc47-7gr5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25190 Advisory: Missing permission check in Jenkins Conjur Secrets Plugin allows enumerating credentials IDs IDs: CVE-2022-25190, GHSA-372f-jc47-7gr5 Record: https://patchnext.com/advisories/cve-2022-25190 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.conjur.jenkins:conjur-credentials 1.0.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.conjur.jenkins:conjur-credentials: affected < 1.0.12; fixed in 1.0.12 ## Suggested inspection (read-only) - Maven org.conjur.jenkins:conjur-credentials: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.conjur.jenkins:conjur-credentials. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-372f-jc47-7gr5 (GitHub-reviewed advisory GHSA-372f-jc47-7gr5 lists affected ranges: Maven org.conjur.jenkins:conjur-credentials >=0 <1.0.12) Commands are suggestions: review each one before running it.
Loading voting…