Skip to content

← Actionable
Medium, CVSS 6.5

Improper Link Resolution Before File Access in Jenkins Pipeline: Shared Groovy Libraries Plugin

CVE-2022-25177GHSA-q234-x887-9rxh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins.workflow:workflow-cps-global-lib 561.va_ce0de3c2d69, 2.21.1, 2.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q234-x887-9rxh lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib >=2.22 =2.19 =0 <2.18.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-25177: 1.74% estimated exploitation activity in the next 30 days; percentile 77.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins Pipeline: Shared Groovy Libraries Plugin 552.vd9cc05b8a2e1 and earlier follows symbolic links to locations outside of the expected Pipeline library when reading files using the libraryResource step, allowing attackers able to configure Pipelines to read arbitrary files on the Jenkins controller file system.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q234-x887-9rxh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-25177

Advisory: Improper Link Resolution Before File Access in Jenkins Pipeline: Shared Groovy Libraries Plugin
IDs: CVE-2022-25177, GHSA-q234-x887-9rxh
Record: https://patchnext.com/advisories/cve-2022-25177 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins.workflow:workflow-cps-global-lib 561.va_ce0de3c2d69, 2.21.1, 2.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib: affected >= 2.22, <= 552.vd9cc05b8a2e1; >= 2.19, < 2.21.1; < 2.18.1; fixed in 561.va_ce0de3c2d69, 2.18.1, 2.21.1

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins.workflow:workflow-cps-global-lib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q234-x887-9rxh (GitHub-reviewed advisory GHSA-q234-x887-9rxh lists affected ranges: Maven org.jenkins-ci.plugins.workflow:workflow-cps-global-lib >=2.22 =2.19 =0 <2.18.1)

Commands are suggestions: review each one before running it.

Loading voting…