Apache Hadoop argument injection vulnerability
CVE-2022-25168GHSA-8wm5-8h9c-47pc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-common 3.3.3, 3.2.4, 2.10.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-common
- Affected
- >= 2.0.0, < 2.10.2>= 3.0.0-alpha, < 3.2.4>= 3.3.0, < 3.3.3
- Fixed in
- 2.10.2, 3.2.4, 3.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wm5-8h9c-47pc lists affected ranges: Maven org.apache.hadoop:hadoop-common >=2.0.0 =3.0.0-alpha =3.3.0 <3.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-25168: 4.59% estimated exploitation activity in the next 30 days; percentile 91.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Hadoop's FileUtil.unTar(File, File) API does not escape the input file name before being passed to the shell. An attacker can inject arbitrary commands. This is only used in Hadoop 3.3 InMemoryAliasMap.completeBootstrapTransfer, which is only ever run by a local user. It has been used in Hadoop 2.x for yarn localization, which does enable remote code execution. It is used in Apache Spark, from the SQL command ADD ARCHIVE. As the ADD ARCHIVE command adds new binaries to the classpath, being able to execute shell scripts does not confer new permissions to the caller. SPARK-38305. "Check existence of file before untarring/zipping", which is included in 3.3.0, 3.1.4, 3.2.2, prevents shell commands being executed, regardless of which version of the hadoop libraries are in use. Users should upgrade to Apache Hadoop 2.10.2, 3.2.4, 3.3.3 or upper (including HADOOP-18136).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wm5-8h9c-47pc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25168 Advisory: Apache Hadoop argument injection vulnerability IDs: CVE-2022-25168, GHSA-8wm5-8h9c-47pc Record: https://patchnext.com/advisories/cve-2022-25168 (revision 1, source checked 26 Oct 2026, 16:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-common 3.3.3, 3.2.4, 2.10.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-common: affected >= 2.0.0, < 2.10.2; >= 3.0.0-alpha, < 3.2.4; >= 3.3.0, < 3.3.3; fixed in 2.10.2, 3.2.4, 3.3.3 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8wm5-8h9c-47pc (GitHub-reviewed advisory GHSA-8wm5-8h9c-47pc lists affected ranges: Maven org.apache.hadoop:hadoop-common >=2.0.0 =3.0.0-alpha =3.3.0 <3.3.3) Commands are suggestions: review each one before running it.
Loading voting…