Skip to content

← Actionable
Medium, CVSS 4.3

Login screen allows message spoofing if SSO is enabled

CVE-2022-24905GHSA-xmg8-99r8-jc2j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd/v2 2.3.4, 2.2.9, 2.1.15; github.com/argoproj/argo-cd 2.1.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2022-24905: 1.30% estimated exploitation activity in the next 30 days; percentile 70.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability was found in Argo CD that allows an attacker to spoof error messages on the login screen when SSO is enabled. In order to exploit this vulnerability, an attacker would have to trick the victim to visit a specially crafted URL which contains the message to be displayed. As far as the research of the Argo CD team concluded, it is not possible to specify any active content (e.g. Javascript) or other HTML fragments (e.g. clickable links) in the spoofed message. Patched versions A patch for this vulnerability has been released in the following Argo CD versions: v2.3.4 v2.2.9 v2.1.15 Workarounds No workaround available. Mitigations It is advised to update to an Argo CD version containing a fix for this issue (see Patched versions above). Credits This vulnerability was discovered by Naufal Septiadi (<naufal@horangi.com) and reported to us in a responsible way. For more information <!-- Use only one of the paragraphs below. Remove all others. -- <!-- For Argo CD --…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xmg8-99r8-jc2j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24905

Advisory: Login screen allows message spoofing if SSO is enabled
IDs: CVE-2022-24905, GHSA-xmg8-99r8-jc2j
Record: https://patchnext.com/advisories/cve-2022-24905 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd/v2 2.3.4, 2.2.9, 2.1.15; github.com/argoproj/argo-cd 2.1.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd/v2: affected >= 2.3.0, < 2.3.4; >= 2.2.0, < 2.2.9; >= 2.0.0, < 2.1.15; fixed in 2.3.4, 2.1.15, 2.2.9
- Go github.com/argoproj/argo-cd: affected <= 1.8.7; fixed in 2.1.15

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd/v2: check the installed version with your package manager.
- Go github.com/argoproj/argo-cd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd/v2, github.com/argoproj/argo-cd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xmg8-99r8-jc2j (GitHub-reviewed advisory GHSA-xmg8-99r8-jc2j lists affected ranges: Go github.com/argoproj/argo-cd/v2 >=2.3.0 =2.2.0 =2.0.0 =0 <=1.8.7)

Commands are suggestions: review each one before running it.

Loading voting…