Skip to content

← Actionable
High, CVSS 7.7

Improper path handling in Kustomization files allows for denial of service

CVE-2022-24878GHSA-7pwf-jg34-hxwp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fluxcd/kustomize-controller 0.24.0; github.com/fluxcd/flux2 0.29.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:H
EPSS
  • CVE-2022-24878: 1.02% estimated exploitation activity in the next 30 days; percentile 63.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The kustomize-controller enables the use of Kustomize’s functionality when applying Kubernetes declarative state onto a cluster. A malicious user can use a specially crafted kustomization.yaml to cause Denial of Service at controller level. In multi-tenancy deployments this can lead to multiple tenants not being able to apply their Kustomizations until the malicious kustomization.yaml is removed and the controller restarted. Impact Within the affected versions, users with write access to a Flux source are able to craft a malicious kustomization.yaml file which causes the controller to enter an endless loop. Patches This vulnerability was fixed in kustomize-controller v0.24.0 and included in flux2 v0.29.0 released on 2022-04-20. The changes introduce better handling of Kustomization files blocking references that could lead to endless loops. Credits The Flux engineering team found and patched this vulnerability. For more information If you have any questions or comments about this…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7pwf-jg34-hxwp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24878

Advisory: Improper path handling in Kustomization files allows for denial of service
IDs: CVE-2022-24878, GHSA-7pwf-jg34-hxwp
Record: https://patchnext.com/advisories/cve-2022-24878 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/fluxcd/kustomize-controller 0.24.0; github.com/fluxcd/flux2 0.29.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/fluxcd/kustomize-controller: affected >= 0.16.0, < 0.24.0; fixed in 0.24.0
- Go github.com/fluxcd/flux2: affected >= 0.19.0, < 0.29.0; fixed in 0.29.0

## Suggested inspection (read-only)
- Go github.com/fluxcd/kustomize-controller: check the installed version with your package manager.
- Go github.com/fluxcd/flux2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/fluxcd/kustomize-controller, github.com/fluxcd/flux2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7pwf-jg34-hxwp (GitHub-reviewed advisory GHSA-7pwf-jg34-hxwp lists affected ranges: Go github.com/fluxcd/kustomize-controller >=0.16.0 =0.19.0 <0.29.0)

Commands are suggestions: review each one before running it.

Loading voting…