Skip to content

← Actionable
Medium, CVSS 6.1amended

NextAuth.js default redirect callback vulnerable to open redirects

CVE-2022-24858GHSA-f9wg-5f46-cjmw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 4.3.2, 3.29.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm next-auth

    Affected
    < 3.29.2>= 4.0.0, < 4.3.2
    Fixed in
    4.3.2, 3.29.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
EPSS
  • CVE-2022-24858: 0.79% estimated exploitation activity in the next 30 days; percentile 56.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

next-auth v3 users before version 3.29.2 are impacted. (We recommend upgrading to v4 in most cases. See our migration guide).next-auth v4 users before version 4.3.2 are impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option: If you already have a redirect callback, make sure that you match the incoming url origin against the baseUrl.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f9wg-5f46-cjmw

  2. Revision 1 · created ·

    Published from osv record GHSA-f9wg-5f46-cjmw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24858

Advisory: NextAuth.js default redirect callback vulnerable to open redirects
IDs: CVE-2022-24858, GHSA-f9wg-5f46-cjmw
Record: https://patchnext.com/advisories/cve-2022-24858 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: next-auth 4.3.2, 3.29.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm next-auth: affected < 3.29.2; >= 4.0.0, < 4.3.2; fixed in 4.3.2, 3.29.2

## Suggested inspection (read-only)
- `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on next-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f9wg-5f46-cjmw (OSV record GHSA-f9wg-5f46-cjmw lists affected ranges: npm next-auth >=0 =4.0.0 <4.3.2 (fixed))
- Verified: https://github.com/advisories/GHSA-f9wg-5f46-cjmw (GitHub-reviewed advisory GHSA-f9wg-5f46-cjmw lists affected ranges: npm next-auth >=0 =4.0.0 <4.3.2)

Commands are suggestions: review each one before running it.

Loading voting…