Skip to content

← Actionable
High, CVSS 7.2

Improper Input Validation in GeoServer

CVE-2022-24847GHSA-4pm3-f52j-8ggh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-main 2.20.4, 2.19.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-24847: 1.56% estimated exploitation activity in the next 30 days; percentile 75.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The GeoServer security mechanism can perform an unchecked JNDI lookup, which in turn can be used to perform class deserialization and result in arbitrary code execution. The same can happen while configuring data stores with data sources located in JNDI, or while setting up the disk quota mechanism. In order to perform any of the above changes, the attack needs to have obtained admin rights and use either the GeoServer GUI, or its REST API. Patches The lookups are going to be restricted in GeoServer 2.21.0, 2.20.4, 2.19.6. Workarounds Protection can be achieved by making the GUI (geoserver/web), the REST configuration (geoserver/rest) and the embedded GeoWebCache configuration (geoserver/gwc/rest) unreachable from remote hosts, in addition to protecting access to the file system where the GeoServer configuration is stored.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4pm3-f52j-8ggh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24847

Advisory: Improper Input Validation in GeoServer
IDs: CVE-2022-24847, GHSA-4pm3-f52j-8ggh
Record: https://patchnext.com/advisories/cve-2022-24847 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-main 2.20.4, 2.19.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geoserver:gs-main: affected >= 2.20.0, < 2.20.4; < 2.19.6; fixed in 2.20.4, 2.19.6

## Suggested inspection (read-only)
- Maven org.geoserver:gs-main: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geoserver:gs-main.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4pm3-f52j-8ggh (GitHub-reviewed advisory GHSA-4pm3-f52j-8ggh lists affected ranges: Maven org.geoserver:gs-main >=2.20.0 =0 <2.19.6)

Commands are suggestions: review each one before running it.

Loading voting…