Skip to content

← Actionable
High, CVSS 7.5

org.nokogiri:nekohtml vulnerable to Uncontrolled Resource Consumption

CVE-2022-24839GHSA-9849-p7jc-9rmv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.nokogiri:nekohtml 1.9.22.noko2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-24839: 2.17% estimated exploitation activity in the next 30 days; percentile 82.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The fork of org.cyberneko.html used by Nokogiri (Rubygem) raises a java.lang.OutOfMemoryError exception when parsing ill-formed HTML markup. Severity The maintainers have evaluated this as High Severity 7.5 (CVSS3.1). Mitigation Upgrade to = 1.9.22.noko2. Credit This vulnerability was reported by 이형관 (windshock). References CWE-400 Uncontrolled Resource Consumption Notes The upstream library org.cyberneko.html is no longer maintained. Nokogiri uses its own fork of this library located at https://github.com/sparklemotion/nekohtml and this CVE applies only to that fork. Other forks of nekohtml may have a similar vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9849-p7jc-9rmv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24839

Advisory: org.nokogiri:nekohtml vulnerable to Uncontrolled Resource Consumption
IDs: CVE-2022-24839, GHSA-9849-p7jc-9rmv
Record: https://patchnext.com/advisories/cve-2022-24839 (revision 1, source checked 26 Oct 2026, 16:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.nokogiri:nekohtml 1.9.22.noko2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.nokogiri:nekohtml: affected < 1.9.22.noko2; fixed in 1.9.22.noko2

## Suggested inspection (read-only)
- Maven org.nokogiri:nekohtml: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.nokogiri:nekohtml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9849-p7jc-9rmv (GitHub-reviewed advisory GHSA-9849-p7jc-9rmv lists affected ranges: Maven org.nokogiri:nekohtml >=0 <1.9.22.noko2)

Commands are suggestions: review each one before running it.

Loading voting…