Persistent Cross-site Scripting vulnerability in PrivateBin
CVE-2022-24833GHSA-cqcc-mm6x-vmvw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (privatebin/privatebin 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist privatebin/privatebin
- Affected
- >= 0.21, < 1.4.0
- Fixed in
- 1.4.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cqcc-mm6x-vmvw lists affected ranges: Packagist privatebin/privatebin >=0.21 <1.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2022-24833: 1.36% estimated exploitation activity in the next 30 days; percentile 71.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present since attachments with image preview got introduced in v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. As a consequence, we have mitigated the vulnerability in the preview and urge server administrators to either upgrade to a version with the fix or to ensure the content security policy of their instance is set correctly, ideally both. Additionally, we expanded our directory listing tool with a checking mechanism and highly suggest server administrators to check their instance there and, should there be a warning regarding the content security policy adjust the CSP to our…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cqcc-mm6x-vmvw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24833 Advisory: Persistent Cross-site Scripting vulnerability in PrivateBin IDs: CVE-2022-24833, GHSA-cqcc-mm6x-vmvw Record: https://patchnext.com/advisories/cve-2022-24833 (revision 1, source checked 26 Oct 2026, 13:59 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: privatebin/privatebin 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist privatebin/privatebin: affected >= 0.21, < 1.4.0; fixed in 1.4.0 ## Suggested inspection (read-only) - Packagist privatebin/privatebin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on privatebin/privatebin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cqcc-mm6x-vmvw (GitHub-reviewed advisory GHSA-cqcc-mm6x-vmvw lists affected ranges: Packagist privatebin/privatebin >=0.21 <1.4.0) Commands are suggestions: review each one before running it.
Loading voting…