Missing input validation can lead to command execution in composer
CVE-2022-24828GHSA-x7cr-6qr6-2hh6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (composer/composer 2.3.5, 2.2.12, 1.10.26), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist composer/composer
- Affected
- < 1.10.26>= 2.0, < 2.2.12>= 2.3, < 2.3.5
- Fixed in
- 2.2.12, 2.3.5, 1.10.26
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x7cr-6qr6-2hh6 lists affected ranges: Packagist composer/composer >=0 =2.0 =2.3 <2.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2022-24828: 1.89% estimated exploitation activity in the next 30 days; percentile 79.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Composer method VcsDriver::getFileContent() with user-controlled $file or $identifier arguments is susceptible to an argument injection vulnerability. It can be leveraged to gain arbitrary command execution if the Mercurial or the Git driver are used. This led to a vulnerability on Packagist.org and Private Packagist, i.e., using the composer.json readme field as a vector for injecting parameters into the $file argument for the Mercurial driver or via the $identifier argument for the Git and Mercurial drivers. Composer itself can be attacked through branch names by anyone controlling a Git or Mercurial repository, which is explicitly listed by URL in a project's composer.json. To the best of our knowledge, this was not actively exploited. The vulnerability has been patched on Packagist.org and Private Packagist within a day of the vulnerability report.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x7cr-6qr6-2hh6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24828 Advisory: Missing input validation can lead to command execution in composer IDs: CVE-2022-24828, GHSA-x7cr-6qr6-2hh6 Record: https://patchnext.com/advisories/cve-2022-24828 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: composer/composer 2.3.5, 2.2.12, 1.10.26. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist composer/composer: affected < 1.10.26; >= 2.0, < 2.2.12; >= 2.3, < 2.3.5; fixed in 2.2.12, 2.3.5, 1.10.26 ## Suggested inspection (read-only) - Packagist composer/composer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on composer/composer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x7cr-6qr6-2hh6 (GitHub-reviewed advisory GHSA-x7cr-6qr6-2hh6 lists affected ranges: Packagist composer/composer >=0 =2.0 =2.3 <2.3.5) Commands are suggestions: review each one before running it.
Loading voting…