Denial of Service vulnerability in @podium/layout and @podium/proxy
CVE-2022-24822GHSA-3hjg-vc7r-rcrw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@podium/layout 4.6.110; @podium/proxy 4.2.74), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @podium/layout
- Affected
- < 4.6.110
- Fixed in
- 4.6.110
npm @podium/proxy
- Affected
- < 4.2.74
- Fixed in
- 4.2.74
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3hjg-vc7r-rcrw lists affected ranges: npm @podium/layout >=0 =0 <4.2.74 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3hjg-vc7r-rcrw lists affected ranges: npm @podium/layout >=0 =0 <4.2.74
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-24822: 1.66% estimated exploitation activity in the next 30 days; percentile 76.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker using the Trailer header as part of the request against proxy endpoints has the ability to take down the server. All Podium layouts that include podlets with proxy endpoints are affected. Patches @podium/layout which is the main way developers/users are vulnerable to this exploit, has been patched in version 4.6.110. All earlier versions are vulnerable. @podium/proxy which is the source of the vulnerability and is used by @podium/layout has been patched in version 4.2.74. All earlier versions are vulnerable. Workarounds It is not easily possible to work around this issue without upgrading. We recommend upgrading @podium/layout and/or @podium/proxy as soon as possible. For more information If you have any questions or comments about this advisory: Open an issue in podium-lib/issues Credits The vulnerability was reported by krynos from Ercoli Consulting via FINN.no's private bug bounty program
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3hjg-vc7r-rcrw
- Revision 1 · created ·
Published from osv record GHSA-3hjg-vc7r-rcrw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24822 Advisory: Denial of Service vulnerability in @podium/layout and @podium/proxy IDs: CVE-2022-24822, GHSA-3hjg-vc7r-rcrw Record: https://patchnext.com/advisories/cve-2022-24822 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @podium/layout 4.6.110; @podium/proxy 4.2.74. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @podium/layout: affected < 4.6.110; fixed in 4.6.110 - npm @podium/proxy: affected < 4.2.74; fixed in 4.2.74 ## Suggested inspection (read-only) - `npm ls @podium/layout --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @podium/proxy --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @podium/layout, @podium/proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3hjg-vc7r-rcrw (OSV record GHSA-3hjg-vc7r-rcrw lists affected ranges: npm @podium/layout >=0 =0 <4.2.74 (fixed)) - Verified: https://github.com/advisories/GHSA-3hjg-vc7r-rcrw (GitHub-reviewed advisory GHSA-3hjg-vc7r-rcrw lists affected ranges: npm @podium/layout >=0 =0 <4.2.74) Commands are suggestions: review each one before running it.
Loading voting…