Skip to content

← Actionable
High, CVSS 8.1amended

SQL Injection when creating an application with Reactive SQL backend

CVE-2022-24815GHSA-qjmq-8hjr-qcv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (generator-jhipster 7.8.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-24815: 1.38% estimated exploitation activity in the next 30 days; percentile 72.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact SQL Injection vulnerability in entities for applications generated with the option "reactive with Spring WebFlux" enabled and an SQL database using r2dbc. Applications created without "reactive with Spring WebFlux" and applications with NoSQL databases are not affected. If you have generated a microservice Gateway using the affected version, you might be impacted as Gateways are reactive by default. Currently, SQL injection is possible in the findAllBy(Pageable pageable, Criteria criteria) method of an entity repository class generated in these applications as the where clause using Criteria for queries are not sanitized and user input is passed on as it is by the criteria. Impacted applications - Monolith and microservice applications with SQL database and reactive with Spring WebFlux combination (other combinations are not affected and the issue is only present when you generate entities) - Gateway applications with SQL database (issue will appear only when generating…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qjmq-8hjr-qcv6

  2. Revision 1 · created ·

    Published from osv record GHSA-qjmq-8hjr-qcv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24815

Advisory: SQL Injection when creating an application with Reactive SQL backend
IDs: CVE-2022-24815, GHSA-qjmq-8hjr-qcv6
Record: https://patchnext.com/advisories/cve-2022-24815 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: generator-jhipster 7.8.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm generator-jhipster: affected >= 7.0.0, < 7.8.1; fixed in 7.8.1

## Suggested inspection (read-only)
- `npm ls generator-jhipster --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on generator-jhipster.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qjmq-8hjr-qcv6 (OSV record GHSA-qjmq-8hjr-qcv6 lists affected ranges: npm generator-jhipster >=7.0.0 <7.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qjmq-8hjr-qcv6 (GitHub-reviewed advisory GHSA-qjmq-8hjr-qcv6 lists affected ranges: npm generator-jhipster >=7.0.0 <7.8.1)

Commands are suggestions: review each one before running it.

Loading voting…