Skip to content

← Actionable
High, CVSS 8.8amended

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in directus

CVE-2022-24814GHSA-xmjj-3c76-5w84

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 9.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 9.7.0
    Fixed in
    9.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-24814: 1.03% estimated exploitation activity in the next 30 days; percentile 63.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Unauthorized JavaScript can be executed by inserting an iframe into the rich text html interface that links to a file uploaded HTML file that loads another uploaded JS file in its script tag. This satisfies the regular content security policy header, which in turn allows the file to run any arbitrary JS. Patches This was resolved in https://github.com/directus/directus/pull/12020 which is released in 9.7.0 Workarounds You can disable the live embed in the WYSIWYG by adding { "medialiveembeds": false } to the Options Overrides option of the Rich Text HTML interface. References https://github.com/directus/directus/pull/12020 For more information If you have any questions or comments about this advisory: Open an issue in directus/directus Email us at security@directus.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xmjj-3c76-5w84

  2. Revision 1 · created ·

    Published from osv record GHSA-xmjj-3c76-5w84

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24814

Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in directus
IDs: CVE-2022-24814, GHSA-xmjj-3c76-5w84
Record: https://patchnext.com/advisories/cve-2022-24814 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 9.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 9.7.0; fixed in 9.7.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xmjj-3c76-5w84 (OSV record GHSA-xmjj-3c76-5w84 lists affected ranges: npm directus >=0 <9.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-xmjj-3c76-5w84 (GitHub-reviewed advisory GHSA-xmjj-3c76-5w84 lists affected ranges: npm directus >=0 <9.7.0)

Commands are suggestions: review each one before running it.

Loading voting…