Skip to content

← Actionable
Critical, CVSS 10.0

Command Injection vulnerability in asciidoctor-include-ext

CVE-2022-24803GHSA-v222-6mr4-qj29

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (asciidoctor-include-ext 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-24803: 2.69% estimated exploitation activity in the next 30 days; percentile 85.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Applications using Asciidoctor (Ruby) with asciidoctor-include-ext (prior to version 0.4.0), which render user-supplied input in AsciiDoc markup, may allow an attacker to execute arbitrary system commands on the host operating system. ~~This attack is possible even when allow-uri-read is disabled!~~ (EDIT: it’s not) Patches The vulnerability has been fixed in commit c7ea001 (and further improved in cbaccf3), which is included in version 0.4.0. Workarounds References https://sakurity.com/blog/2015/02/28/openuri.html Credits This vulnerability was discovered by Joern Schneeweisz from the GitLab Security Research Team. For more information See commit message c7ea001. If you have any questions or comments about this advisory open an issue in jirutka/asciidoctor-include-ext.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v222-6mr4-qj29

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24803

Advisory: Command Injection vulnerability in asciidoctor-include-ext
IDs: CVE-2022-24803, GHSA-v222-6mr4-qj29
Record: https://patchnext.com/advisories/cve-2022-24803 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: asciidoctor-include-ext 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems asciidoctor-include-ext: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- RubyGems asciidoctor-include-ext: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on asciidoctor-include-ext.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v222-6mr4-qj29 (GitHub-reviewed advisory GHSA-v222-6mr4-qj29 lists affected ranges: RubyGems asciidoctor-include-ext >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…