Skip to content

← Actionable
Critical, CVSS 9.2amended

Inconsistent Interpretation of HTTP Requests in twisted.web

CVE-2022-24801GHSA-c2jg-hw38-jrqq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (twisted 22.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI twisted

    Affected
    < 22.4.0
    Fixed in
    22.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-24801: 2.80% estimated exploitation activity in the next 30 days; percentile 86.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Twisted Web HTTP 1.1 server, located in the twisted.web.http module, parsed several HTTP request constructs more leniently than permitted by RFC 7230: 1. The Content-Length header value could have a + or - prefix. 2. Illegal characters were permitted in chunked extensions, such as the LF (\n) character. 3. Chunk lengths, which are expressed in hexadecimal format, could have a prefix of 0x. 4. HTTP headers were stripped of all leading and trailing ASCII whitespace, rather than only space and HTAB (\t). This non-conformant parsing can lead to desync if requests pass through multiple HTTP parsers, potentially resulting in HTTP request smuggling. Impact You may be affected if: 1. You use Twisted Web's HTTP 1.1 server and/or proxy 2. You also pass requests through a different HTTP server and/or proxy The specifics of the other HTTP parser matter. The original report notes that some versions of Apache Traffic Server and HAProxy have been vulnerable in the past. HTTP request smuggling…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-c2jg-hw38-jrqq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-c2jg-hw38-jrqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24801

Advisory: Inconsistent Interpretation of HTTP Requests in twisted.web
IDs: CVE-2022-24801, GHSA-c2jg-hw38-jrqq
Record: https://patchnext.com/advisories/cve-2022-24801 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: twisted 22.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI twisted: affected < 22.4.0; fixed in 22.4.0

## Suggested inspection (read-only)
- `python -m pip show twisted`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on twisted.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c2jg-hw38-jrqq (OSV record GHSA-c2jg-hw38-jrqq lists affected ranges: PyPI twisted >=0 <22.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c2jg-hw38-jrqq (GitHub-reviewed advisory GHSA-c2jg-hw38-jrqq lists affected ranges: PyPI twisted >=0 <22.4.0)

Commands are suggestions: review each one before running it.

Loading voting…