Skip to content

← Actionable
High, CVSS 8.1

October CMS upload process vulnerable to RCE via Race Condition

CVE-2022-24800GHSA-8v7h-cpc2-r8jp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/system 2.2.15, 1.1.12, 1.0.476), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist october/system

    Affected
    < 1.0.476>= 1.1.0, < 1.1.12>= 2.0.0, < 2.2.15
    Fixed in
    1.1.12, 1.0.476, 2.2.15

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-24800: 1.46% estimated exploitation activity in the next 30 days; percentile 73.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This advisory affects plugins that expose the October\Rain\Database\Attach\File::fromData as a public interface. This vulnerability does not affect vanilla installations of October CMS since this method is not exposed or used by the system internally or externally. When the developer allows the user to specify their own filename in the fromData method, an unauthenticated user can perform remote code execution (RCE) by exploiting a race condition in the temporary storage directory. Patches The issue has been patched in Build 476 (v1.0.476) and v1.1.12 and v2.2.15. Workarounds Apply https://github.com/octobercms/library/commit/fe569f3babf3f593be2b1e0a4ae0283506127a83 to your installation manually if unable to upgrade to Build 476 (v1.0.476) or v1.1.12 or v2.2.15. References Credits to: - DucNT, HungTD and GiangVQ from RedTeam@VNG Security Response Center. For more information If you have any questions or comments about this advisory: - Email us at hello@octobercms.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8v7h-cpc2-r8jp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24800

Advisory: October CMS upload process vulnerable to RCE via Race Condition
IDs: CVE-2022-24800, GHSA-8v7h-cpc2-r8jp
Record: https://patchnext.com/advisories/cve-2022-24800 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: october/system 2.2.15, 1.1.12, 1.0.476. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist october/system: affected < 1.0.476; >= 1.1.0, < 1.1.12; >= 2.0.0, < 2.2.15; fixed in 1.1.12, 1.0.476, 2.2.15

## Suggested inspection (read-only)
- Packagist october/system: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on october/system.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8v7h-cpc2-r8jp (GitHub-reviewed advisory GHSA-8v7h-cpc2-r8jp lists affected ranges: Packagist october/system >=0 =1.1.0 =2.0.0 <2.2.15)

Commands are suggestions: review each one before running it.

Loading voting…