Exposure of debug and metrics endpoints in Pomerium
CVE-2022-24797GHSA-q98f-2x4p-prjr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pomerium/pomerium 0.17.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/pomerium/pomerium
- Affected
- >= 0.16.0, < 0.17.1
- Fixed in
- 0.17.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q98f-2x4p-prjr lists affected ranges: Go github.com/pomerium/pomerium >=0.16.0 <0.17.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-24797: 1.38% estimated exploitation activity in the next 30 days; percentile 72.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In distributed service mode, Pomerium's Authenticate service exposes pprof debug and prometheus metrics handlers to untrusted traffic. This can leak potentially sensitive environmental information or lead to limited denial of service conditions. Patches v0.17.1 Workarounds Block access to /debug and /metrics paths on the authenticate service. This can be done with any L7 proxy, including Pomerium's own proxy service. References https://github.com/pomerium/pomerium/pull/3212 For more information If you have any questions or comments about this advisory: Open an issue in Pomerium Email us at security@pomerium.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q98f-2x4p-prjr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24797 Advisory: Exposure of debug and metrics endpoints in Pomerium IDs: CVE-2022-24797, GHSA-q98f-2x4p-prjr Record: https://patchnext.com/advisories/cve-2022-24797 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/pomerium/pomerium 0.17.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/pomerium/pomerium: affected >= 0.16.0, < 0.17.1; fixed in 0.17.1 ## Suggested inspection (read-only) - Go github.com/pomerium/pomerium: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/pomerium/pomerium. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q98f-2x4p-prjr (GitHub-reviewed advisory GHSA-q98f-2x4p-prjr lists affected ranges: Go github.com/pomerium/pomerium >=0.16.0 <0.17.1) Commands are suggestions: review each one before running it.
Loading voting…