Skip to content

← Actionable
Medium, CVSS 5.9

Buffer Overflow in yajl-ruby

CVE-2022-24795GHSA-jj47-x69x-mxrm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yajl-ruby 1.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems yajl-ruby

    Affected
    <= 1.4.2
    Fixed in
    1.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2022-24795: 3.47% estimated exploitation activity in the next 30 days; percentile 89.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

NOTE: A previous patch, 1.4.2, fixed the heap memory issue, but could still lead to a DoS infinite loop. Please update to version 1.4.3 The 1.x branch and the 2.x branch of yajl contain an integer overflow which leads to subsequent heap memory corruption when dealing with large (~2GB) inputs. Details The reallocation logic at yajlbuf.c#L64 may result in the need 32bit integer wrapping to 0 when need approaches a value of 0x80000000 (i.e. ~2GB of data), which results in a reallocation of buf-alloc into a small heap chunk. These integers are declared as sizet in the 2.x branch of yajl, which practically prevents the issue from triggering on 64bit platforms, however this does not preclude this issue triggering on 32bit builds on which sizet is a 32bit integer. Subsequent population of this under-allocated heap chunk is based on the original buffer size, leading to heap memory corruption. Impact We rate this as a moderate severity vulnerability which mostly impacts process availability…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jj47-x69x-mxrm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24795

Advisory: Buffer Overflow in yajl-ruby
IDs: CVE-2022-24795, GHSA-jj47-x69x-mxrm
Record: https://patchnext.com/advisories/cve-2022-24795 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yajl-ruby 1.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems yajl-ruby: affected <= 1.4.2; fixed in 1.4.3

## Suggested inspection (read-only)
- RubyGems yajl-ruby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yajl-ruby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jj47-x69x-mxrm (GitHub-reviewed advisory GHSA-jj47-x69x-mxrm lists affected ranges: RubyGems yajl-ruby >=0 <=1.4.2)

Commands are suggestions: review each one before running it.

Loading voting…