URL Redirection to Untrusted Site ('Open Redirect') in express-openid-connect
CVE-2022-24794GHSA-7p99-3798-f85c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-openid-connect 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.7.2
- Fixed in
- 2.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7p99-3798-f85c lists affected ranges: npm express-openid-connect >=0 <2.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7p99-3798-f85c lists affected ranges: npm express-openid-connect >=0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2022-24794: 0.74% estimated exploitation activity in the next 30 days; percentile 54.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users of the requiresAuth middleware, either directly or through the default authRequired option, are vulnerable to an Open Redirect when the middleware is applied to a catch all route. If all routes under example.com are protected with the requiresAuth middleware, a visit to http://example.com//google.com will be redirected to google.com after login because the original url reported by the Express framework is not properly sanitised. Am I affected? You are affected by this vulnerability if you are using the requiresAuth middleware on a catch all route or the default authRequired option and express-openid-connect version <=2.7.1. How to fix that? Upgrade to version =2.7.2 Will this update impact my users? The fix provided in the patch will not affect your users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7p99-3798-f85c
- Revision 1 · created ·
Published from osv record GHSA-7p99-3798-f85c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24794
Advisory: URL Redirection to Untrusted Site ('Open Redirect') in express-openid-connect
IDs: CVE-2022-24794, GHSA-7p99-3798-f85c
Record: https://patchnext.com/advisories/cve-2022-24794 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: express-openid-connect 2.7.2. A vendor fix does not mean a deployment is fixed.
## Affected components
- npm express-openid-connect: affected < 2.7.2; fixed in 2.7.2
## Suggested inspection (read-only)
- `npm ls express-openid-connect --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on express-openid-connect.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-7p99-3798-f85c (OSV record GHSA-7p99-3798-f85c lists affected ranges: npm express-openid-connect >=0 <2.7.2 (fixed))
- Verified: https://github.com/advisories/GHSA-7p99-3798-f85c (GitHub-reviewed advisory GHSA-7p99-3798-f85c lists affected ranges: npm express-openid-connect >=0 <2.7.2)
Commands are suggestions: review each one before running it.Loading voting…