Incorrect Comparison in Vyper
CVE-2022-24787GHSA-7vrm-3jc8-5wwm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vyper 0.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vyper
- Affected
- < 0.3.2
- Fixed in
- 0.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7vrm-3jc8-5wwm lists affected ranges: PyPI vyper >=0 <0.3.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7vrm-3jc8-5wwm lists affected ranges: PyPI vyper >=0 <0.3.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-24787: 1.03% estimated exploitation activity in the next 30 days; percentile 63.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact bytestrings can have dirty bytes in them, resulting in the word-for-word comparison to give incorrect results, e.g. even without dirty nonzero bytes, because there is no comparison of the length, two bytestrings can compare to equal if one ends with "\x00". Patches fixed in https://github.com/vyperlang/vyper/commit/2c73f8352635c0a433423a5b94740de1a118e508
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7vrm-3jc8-5wwm
- Revision 1 · created ·
Published from osv record GHSA-7vrm-3jc8-5wwm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24787 Advisory: Incorrect Comparison in Vyper IDs: CVE-2022-24787, GHSA-7vrm-3jc8-5wwm Record: https://patchnext.com/advisories/cve-2022-24787 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vyper 0.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vyper: affected < 0.3.2; fixed in 0.3.2 ## Suggested inspection (read-only) - `python -m pip show vyper`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vyper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7vrm-3jc8-5wwm (OSV record GHSA-7vrm-3jc8-5wwm lists affected ranges: PyPI vyper >=0 <0.3.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7vrm-3jc8-5wwm (GitHub-reviewed advisory GHSA-7vrm-3jc8-5wwm lists affected ranges: PyPI vyper >=0 <0.3.2) Commands are suggestions: review each one before running it.
Loading voting…