Skip to content

← Actionable
Critical, CVSS 10.0

Sandbox bypass leading to arbitrary code execution in Deno

CVE-2022-24783GHSA-838h-jqp6-cf2f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno 1.20.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io deno

    Affected
    >= 1.18.0, < 1.20.3
    Fixed in
    1.20.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2022-24783: 1.15% estimated exploitation activity in the next 30 days; percentile 66.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The versions of Deno between release 1.18.0 and 1.20.2 (inclusive) are vulnerable to an attack where a malicious actor controlling the code executed in a Deno runtime could bypass permission checks and execute arbitrary shell code. There is no evidence that this vulnerability has been exploited in the wild. This vulnerability does not affect users of Deno Deploy. Patches The vulnerability has been patched in Deno 1.20.3. Workarounds There is no workaround. All users are recommended to upgrade to 1.20.3 immediately --- The cause of this error was that certain FFI operations did not correctly check for permissions. The issue was fixed in this pull request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-838h-jqp6-cf2f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24783

Advisory: Sandbox bypass leading to arbitrary code execution in Deno
IDs: CVE-2022-24783, GHSA-838h-jqp6-cf2f
Record: https://patchnext.com/advisories/cve-2022-24783 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deno 1.20.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io deno: affected >= 1.18.0, < 1.20.3; fixed in 1.20.3

## Suggested inspection (read-only)
- crates.io deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-838h-jqp6-cf2f (GitHub-reviewed advisory GHSA-838h-jqp6-cf2f lists affected ranges: crates.io deno >=1.18.0 <1.20.3)

Commands are suggestions: review each one before running it.

Loading voting…