Skip to content

← Actionable
Medium, CVSS 5.9

Moby (Docker Engine) started with non-empty inheritable Linux process capabilities

CVE-2022-24769GHSA-2mm7-x5h6-5pvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/docker/docker 20.10.14; github.com/moby/moby 20.10.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS
  • CVE-2022-24769: 0.49% estimated exploitation activity in the next 30 days; percentile 42.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A bug was found in Moby (Docker Engine) where containers were incorrectly started with non-empty inheritable Linux process capabilities, creating an atypical Linux environment and enabling programs with inheritable file capabilities to elevate those capabilities to the permitted set during execve(2). Normally, when executable programs have specified permitted file capabilities, otherwise unprivileged users and processes can execute those programs and gain the specified file capabilities up to the bounding set. Due to this bug, containers which included executable programs with inheritable file capabilities allowed otherwise unprivileged users and processes to additionally gain these inheritable file capabilities up to the container's bounding set. Containers which use Linux users and groups to perform privilege separation inside the container are most directly impacted. This bug did not affect the container security sandbox as the inheritable set never contained more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2mm7-x5h6-5pvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24769

Advisory: Moby (Docker Engine) started with non-empty inheritable Linux process capabilities
IDs: CVE-2022-24769, GHSA-2mm7-x5h6-5pvq
Record: https://patchnext.com/advisories/cve-2022-24769 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/docker/docker 20.10.14; github.com/moby/moby 20.10.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/docker/docker: affected < 20.10.14; fixed in 20.10.14
- Go github.com/moby/moby: affected < 20.10.14; fixed in 20.10.14

## Suggested inspection (read-only)
- Go github.com/docker/docker: check the installed version with your package manager.
- Go github.com/moby/moby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/docker/docker, github.com/moby/moby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2mm7-x5h6-5pvq (GitHub-reviewed advisory GHSA-2mm7-x5h6-5pvq lists affected ranges: Go github.com/moby/moby >=0 =0 <20.10.14)

Commands are suggestions: review each one before running it.

Loading voting…