Skip to content

← Actionable
Critical, CVSS 9.3amended

Insufficient Protection against HTTP Request Smuggling in mitmproxy

CVE-2022-24766GHSA-gcx2-gvj7-pxv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mitmproxy 8.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-24766: 1.63% estimated exploitation activity in the next 30 days; percentile 76.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In mitmproxy 7.0.4 and below, a malicious client or server is able to perform HTTP request smuggling attacks through mitmproxy. This means that a malicious client/server could smuggle a request/response through mitmproxy as part of another request/response's HTTP message body. While mitmproxy would only see one request, the target server would see multiple requests. A smuggled request is still captured as part of another request's body, but it does not appear in the request list and does not go through the usual mitmproxy event hooks, where users may have implemented custom access control checks or input sanitization. Unless you use mitmproxy to protect an HTTP/1 service, no action is required. Patches The vulnerability has been fixed in mitmproxy 8.0.0 and above. Acknowledgements We thank Zeyu Zhang (@zeyu2001) for responsibly disclosing this vulnerability to the mitmproxy team. Timeline - 2022-03-15: Received initial report. - 2022-03-15: Verified report and confirmed…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-gcx2-gvj7-pxv3

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-gcx2-gvj7-pxv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24766

Advisory: Insufficient Protection against HTTP Request Smuggling in mitmproxy
IDs: CVE-2022-24766, GHSA-gcx2-gvj7-pxv3
Record: https://patchnext.com/advisories/cve-2022-24766 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mitmproxy 8.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mitmproxy: affected < 8.0.0; fixed in 8.0.0

## Suggested inspection (read-only)
- `python -m pip show mitmproxy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mitmproxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-gcx2-gvj7-pxv3 (OSV record GHSA-gcx2-gvj7-pxv3 lists affected ranges: PyPI mitmproxy >=0 <8.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-gcx2-gvj7-pxv3 (GitHub-reviewed advisory GHSA-gcx2-gvj7-pxv3 lists affected ranges: PyPI mitmproxy >=0 <8.0.0)

Commands are suggestions: review each one before running it.

Loading voting…