Skip to content

← Actionable
Medium, CVSS 6.5amended

Leaking of user information on Cross-Domain communication in sysend

CVE-2022-24762GHSA-4vvg-x86p-mvqc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sysend 1.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm sysend

    Affected
    < 1.10.0
    Fixed in
    1.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2022-24762: 0.68% estimated exploitation activity in the next 30 days; percentile 52.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users that use Cross-Origin communication and send sensitive information make it possible for this data to be intercepted. This is not a big impact because it happens only on the same browser. Patches It has been patched in version 1.10.0 Workarounds The only workaround is to not send sensitive information with sysend messages.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4vvg-x86p-mvqc

  2. Revision 1 · created ·

    Published from osv record GHSA-4vvg-x86p-mvqc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24762

Advisory: Leaking of user information on Cross-Domain communication in sysend
IDs: CVE-2022-24762, GHSA-4vvg-x86p-mvqc
Record: https://patchnext.com/advisories/cve-2022-24762 (revision 2, source checked 26 Oct 2026, 12:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sysend 1.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sysend: affected < 1.10.0; fixed in 1.10.0

## Suggested inspection (read-only)
- `npm ls sysend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sysend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vvg-x86p-mvqc (OSV record GHSA-4vvg-x86p-mvqc lists affected ranges: npm sysend >=0 <1.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4vvg-x86p-mvqc (GitHub-reviewed advisory GHSA-4vvg-x86p-mvqc lists affected ranges: npm sysend >=0 <1.10.0)

Commands are suggestions: review each one before running it.

Loading voting…