Skip to content

← Actionable
High, CVSS 8.7amended

HTTP Request Smuggling in waitress

CVE-2022-24761GHSA-4f7p-27jc-3c36

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (waitress 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI waitress

    Affected
    < 2.1.1
    Fixed in
    2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-24761: 1.78% estimated exploitation activity in the next 30 days; percentile 78.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using Waitress behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: - The use of Python's int() to parse strings into integers, leading to +10 to be parsed as 10, or 0x01 to be parsed as 1, where as the standard specifies that the string should contain only digits or hex digits. - Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters Patches This has been fixed in Waitress 2.1.1 Workarounds When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4f7p-27jc-3c36

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4f7p-27jc-3c36

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24761

Advisory: HTTP Request Smuggling in waitress
IDs: CVE-2022-24761, GHSA-4f7p-27jc-3c36
Record: https://patchnext.com/advisories/cve-2022-24761 (revision 3, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: waitress 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI waitress: affected < 2.1.1; fixed in 2.1.1

## Suggested inspection (read-only)
- `python -m pip show waitress`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on waitress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4f7p-27jc-3c36 (OSV record GHSA-4f7p-27jc-3c36 lists affected ranges: PyPI waitress >=0 <2.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-4f7p-27jc-3c36 (GitHub-reviewed advisory GHSA-4f7p-27jc-3c36 lists affected ranges: PyPI waitress >=0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…