Insertion of Sensitive Information into Log File in Jupyter notebook
CVE-2022-24757GHSA-p737-p57g-4cpr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 1.15.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- < 1.15.4
- Fixed in
- 1.15.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p737-p57g-4cpr lists affected ranges: PyPI jupyter-server >=0 <1.15.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p737-p57g-4cpr lists affected ranges: PyPI jupyter-server >=0 <1.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-24757: 1.27% estimated exploitation activity in the next 30 days; percentile 69.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Anytime a 5xx error is triggered, the auth cookie and other header values are recorded in Jupyter Server logs by default. Considering these logs do not require root access, an attacker can monitor these logs, steal sensitive auth/cookie information, and gain access to the Jupyter server. Patches Has the problem been patched? What versions should users upgrade to? Upgrade to Jupyter Server version 1.15.4 For more information If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list security@ipython.org. Credit: @3coins for reporting. Thank you!
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p737-p57g-4cpr
- Revision 1 · created ·
Published from osv record GHSA-p737-p57g-4cpr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24757 Advisory: Insertion of Sensitive Information into Log File in Jupyter notebook IDs: CVE-2022-24757, GHSA-p737-p57g-4cpr Record: https://patchnext.com/advisories/cve-2022-24757 (revision 2, source checked 26 Oct 2026, 13:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 1.15.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected < 1.15.4; fixed in 1.15.4 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p737-p57g-4cpr (OSV record GHSA-p737-p57g-4cpr lists affected ranges: PyPI jupyter-server >=0 <1.15.4 (fixed)) - Verified: https://github.com/advisories/GHSA-p737-p57g-4cpr (GitHub-reviewed advisory GHSA-p737-p57g-4cpr lists affected ranges: PyPI jupyter-server >=0 <1.15.4) Commands are suggestions: review each one before running it.
Loading voting…