Skip to content

← Actionable
Medium, CVSS 5.0amended

Sudden swap of user auth tokens in Volto

CVE-2022-24740GHSA-cfhh-xgwq-5r67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@plone/volto 15.0.0-alpha.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @plone/volto

    Affected
    >= 14.0.0-alpha.6, <= 14.10.0
    Fixed in
    15.0.0-alpha.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2022-24740: 0.59% estimated exploitation activity in the next 30 days; percentile 48.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Due to the usage of an outdated version of the react-cookie library, under the circumstances of given a server high load, it is possible that a user could get his/her auth cookie replaced with the auth cookie from another user, effectively giving him full access to the other users account and privileges. A proven exploit for this vulnerability does not exist, since the exact requisites for it to happen have not been fully clarified, and the attempts to reproduce it under testing conditions have been unsuccessful, but it still can happen randomly and unintentionally in the wild. Patches The patch and fix is present in Volto 15.0.0-alpha.0 (or later). See PR: https://github.com/plone/volto/pull/3051. We recommend upgrading to the final release of Volto 15 as soon as possible if running an affected version. See the upgrade guide https://6-dev-docs.plone.org/volto/upgrade-guide/index.html#upgrading-to-volto-15-x-x Workarounds It is possible to create a fix by manually upgrading…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-cfhh-xgwq-5r67

  2. Revision 1 · created ·

    Published from osv record GHSA-cfhh-xgwq-5r67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24740

Advisory: Sudden swap of user auth tokens in Volto
IDs: CVE-2022-24740, GHSA-cfhh-xgwq-5r67
Record: https://patchnext.com/advisories/cve-2022-24740 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @plone/volto 15.0.0-alpha.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @plone/volto: affected >= 14.0.0-alpha.6, <= 14.10.0; fixed in 15.0.0-alpha.0

## Suggested inspection (read-only)
- `npm ls @plone/volto --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @plone/volto.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-cfhh-xgwq-5r67 (OSV record GHSA-cfhh-xgwq-5r67 lists affected ranges: npm @plone/volto >=14.0.0-alpha.6 <15.0.0-alpha.0 (fixed))
- Verified: https://github.com/advisories/GHSA-cfhh-xgwq-5r67 (GitHub-reviewed advisory GHSA-cfhh-xgwq-5r67 lists affected ranges: npm @plone/volto >=14.0.0-alpha.6 <=14.10.0)

Commands are suggestions: review each one before running it.

Loading voting…