Exposure of Sensitive Information to an Unauthorized Actor in httpie
CVE-2022-24737GHSA-9w4w-cpc8-h2fq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (httpie 3.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI httpie
- Affected
- < 3.1.0
- Fixed in
- 3.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9w4w-cpc8-h2fq lists affected ranges: PyPI httpie >=0 <3.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9w4w-cpc8-h2fq lists affected ranges: PyPI httpie >=0 <3.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2022-24737: 1.65% estimated exploitation activity in the next 30 days; percentile 76.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact HTTPie have the practical concept of sessions, which help users to persistently store some of the state that belongs to the outgoing requests and incoming responses on the disk for further usage. As an example, we can make an authenticated request and save it to a named session called api: Since we have now saved the authentication data to that session, we won‘t have to enter it again and again on every invocation. We can simply reference the session, and HTTPie will use the saved state directly from it: One particular use case of these sessions is storing cookies (commonly referred to as a Cookie Jar). If a response has a Set-Cookie header, HTTPie will parse it and store the actual cookie in the session. And from that point on, all outgoing requests will attach that cookie (in the form of a Cookie header). This is extremely useful, especially when you are dealing with websites which manage their own state on the client-side through cookies. Before 3.1.0, HTTPie didn‘t…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9w4w-cpc8-h2fq
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9w4w-cpc8-h2fq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24737 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in httpie IDs: CVE-2022-24737, GHSA-9w4w-cpc8-h2fq Record: https://patchnext.com/advisories/cve-2022-24737 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: httpie 3.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI httpie: affected < 3.1.0; fixed in 3.1.0 ## Suggested inspection (read-only) - `python -m pip show httpie`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on httpie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9w4w-cpc8-h2fq (OSV record GHSA-9w4w-cpc8-h2fq lists affected ranges: PyPI httpie >=0 <3.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9w4w-cpc8-h2fq (GitHub-reviewed advisory GHSA-9w4w-cpc8-h2fq lists affected ranges: PyPI httpie >=0 <3.1.0) Commands are suggestions: review each one before running it.
Loading voting…