Use of a Key Past its Expiration Date and Insufficient Session Expiration in Maddy Mail Server
CVE-2022-24732GHSA-6cp7-g972-w9m9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/foxcpp/maddy 0.5.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 0.5.4
- Fixed in
- 0.5.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6cp7-g972-w9m9 lists affected ranges: Go github.com/foxcpp/maddy >=0 <0.5.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2022-24732: 0.41% estimated exploitation activity in the next 30 days; percentile 35.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any configuration on any maddy version <0.5.4 using auth.pam is affected. No password expiry or account expiry checking is done when authenticating using PAM. Patches Patch is available as part of the 0.5.4 release. Workarounds If /etc/shadow authentication is used, it is possible to replace auth.pam with auth.shadow which is not affected. It is possible to blacklist expired accounts via existing filtering mechanisms (e.g. authmap to invalid accounts in storage.imapsql). References https://github.com/foxcpp/maddy/blob/3412e59a2c92106e194fa69f2f1017c020037c9c/internal/auth/pam/pam.c https://linux.die.net/man/3/pamacctmgmt For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/foxcpp/maddy Email fox.cpp@disroot.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6cp7-g972-w9m9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24732 Advisory: Use of a Key Past its Expiration Date and Insufficient Session Expiration in Maddy Mail Server IDs: CVE-2022-24732, GHSA-6cp7-g972-w9m9 Record: https://patchnext.com/advisories/cve-2022-24732 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/foxcpp/maddy 0.5.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/foxcpp/maddy: affected < 0.5.4; fixed in 0.5.4 ## Suggested inspection (read-only) - Go github.com/foxcpp/maddy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/foxcpp/maddy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6cp7-g972-w9m9 (GitHub-reviewed advisory GHSA-6cp7-g972-w9m9 lists affected ranges: Go github.com/foxcpp/maddy >=0 <0.5.4) Commands are suggestions: review each one before running it.
Loading voting…