Cross-site Scripting in CKEditor4
CVE-2022-24728GHSA-4fc4-4p5g-6w89
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor4 4.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor4
- Affected
- < 4.18.0
- Fixed in
- 4.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-4fc4-4p5g-6w89 lists affected ranges: npm ckeditor4 >=0 <4.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-24728: 1.20% estimated exploitation activity in the next 30 days; percentile 68.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
- CVE-2022-24729: 2.49% estimated exploitation activity in the next 30 days; percentile 84.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected packages The vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4.
Impact A potential vulnerability has been discovered in CKEditor 4 HTML processing core module. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.18.0.
Patches The problem has been recognized and patched. The fix will be available in version 4.18.0.
For more information Email us at security@cksource.com if you have any questions or comments about this advisory.
Acknowledgements The CKEditor 4 team would like to thank GHSL team member Kevin Backhouse (@kevinbackhouse) for recognizing and reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-4fc4-4p5g-6w89
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24728 Advisory: Cross-site Scripting in CKEditor4 IDs: CVE-2022-24728, GHSA-4fc4-4p5g-6w89 Record: https://patchnext.com/advisories/cve-2022-24728 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor4 4.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor4: affected < 4.18.0; fixed in 4.18.0 ## Suggested inspection (read-only) - `npm ls ckeditor4 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor4. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-4fc4-4p5g-6w89 (OSV record GHSA-4fc4-4p5g-6w89 lists affected ranges: npm ckeditor4 >=0 <4.18.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…