Skip to content

← Actionable
High, CVSS 8.1

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in view_component

CVE-2022-24722GHSA-cm9w-c4rj-r2cf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (view_component 2.49.1, 2.31.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems view_component

    Affected
    >= 2.31.0, < 2.31.2>= 2.32.0, < 2.49.1
    Fixed in
    2.31.2, 2.49.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2022-24722: 1.09% estimated exploitation activity in the next 30 days; percentile 65.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

This is an XSS vulnerability that has the potential to impact anyone using translations with the viewcomponent gem. Data received via user input and passed as an interpolation argument to the translate method is not properly sanitized before display. Versions 2.29.1 and 2.49.1 have been released and fully mitigate the vulnerability. Avoid passing user input to the translate function, or sanitize the inputs before passing them. For more information If you have any questions or comments about this advisory: Open an issue in the github/viewcomponent project

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cm9w-c4rj-r2cf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24722

Advisory: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in view_component
IDs: CVE-2022-24722, GHSA-cm9w-c4rj-r2cf
Record: https://patchnext.com/advisories/cve-2022-24722 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: view_component 2.49.1, 2.31.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems view_component: affected >= 2.31.0, < 2.31.2; >= 2.32.0, < 2.49.1; fixed in 2.31.2, 2.49.1

## Suggested inspection (read-only)
- RubyGems view_component: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on view_component.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cm9w-c4rj-r2cf (GitHub-reviewed advisory GHSA-cm9w-c4rj-r2cf lists affected ranges: RubyGems view_component >=2.31.0 =2.32.0 <2.49.1)

Commands are suggestions: review each one before running it.

Loading voting…