Skip to content

← Actionable
Critical, CVSS 9.8

Remote shell execution vulnerability in image_processing

CVE-2022-24720GHSA-cxf7-qrc5-9446

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (image_processing 1.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2022-24720: 2.69% estimated exploitation activity in the next 30 days; percentile 85.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When using the #apply method from imageprocessing to apply a series of operations that are coming from unsanitized user input, this allows the attacker to execute shell commands: This method is called internally by Active Storage variants, so Active Storage is vulnerable as well. Patches The vulnerability has been fixed in version 1.12.2 of imageprocessing. Workarounds If you're processing based on user input, it's highly recommended that you always sanitize the user input, by allowing only a constrained set of operations. For example:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cxf7-qrc5-9446

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24720

Advisory: Remote shell execution vulnerability in image_processing
IDs: CVE-2022-24720, GHSA-cxf7-qrc5-9446
Record: https://patchnext.com/advisories/cve-2022-24720 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: image_processing 1.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems image_processing: affected < 1.12.2; fixed in 1.12.2

## Suggested inspection (read-only)
- RubyGems image_processing: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on image_processing.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cxf7-qrc5-9446 (GitHub-reviewed advisory GHSA-cxf7-qrc5-9446 lists affected ranges: RubyGems image_processing >=0 <1.12.2)

Commands are suggestions: review each one before running it.

Loading voting…