Skip to content

← Actionable
Low, CVSS 2.1amended

Forwarding of confidentials headers to third parties in fluture-node

CVE-2022-24719GHSA-32x6-qvw6-mxj4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (fluture-node 4.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.1 · CVSS:4.0/AV:A/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-24719: 0.83% estimated exploitation activity in the next 30 days; percentile 57.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Using followRedirects or followRedirectsWith with any of the redirection strategies built into fluture-node 4.0.0 or 4.0.1, paired with a request that includes confidential headers such as Authorization or Cookie, exposes you to a vulnerability where, if the destination server were to redirect the request to a server on a third-party domain, or the same domain over unencrypted HTTP, the headers would be included in the follow-up request and be exposed to the third party, or potential http traffic sniffing. Patches The redirection strategies made available in version 4.0.2 automatically redact confidential headers when a redirect is followed across to another origin. Workarounds Use a custom redirection strategy via the followRedirectsWith function. The custom strategy can be based on the new strategies available in fluture-node@4.0.2. References - This vulnerability was discovered after the announcement of similar vulnerabilities in the follow-redirects package. There is more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-32x6-qvw6-mxj4

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-32x6-qvw6-mxj4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24719

Advisory: Forwarding of confidentials headers to third parties in fluture-node
IDs: CVE-2022-24719, GHSA-32x6-qvw6-mxj4
Record: https://patchnext.com/advisories/cve-2022-24719 (revision 3, source checked 26 Oct 2026, 12:57 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: fluture-node 4.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm fluture-node: affected >= 4.0.0, < 4.0.2; fixed in 4.0.2

## Suggested inspection (read-only)
- `npm ls fluture-node --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fluture-node.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-32x6-qvw6-mxj4 (OSV record GHSA-32x6-qvw6-mxj4 lists affected ranges: npm fluture-node >=4.0.0 <4.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-32x6-qvw6-mxj4 (GitHub-reviewed advisory GHSA-32x6-qvw6-mxj4 lists affected ranges: npm fluture-node >=4.0.0 <4.0.2)

Commands are suggestions: review each one before running it.

Loading voting…