Cross site scripting in @awsui/components-react
CVE-2022-24709GHSA-mf22-92pm-m8p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@awsui/components-react 3.0.367), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 3.0.367
- Fixed in
- 3.0.367
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mf22-92pm-m8p8 lists affected ranges: npm @awsui/components-react >=0 <3.0.367 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mf22-92pm-m8p8 lists affected ranges: npm @awsui/components-react >=0 <3.0.367
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-24709: 0.69% estimated exploitation activity in the next 30 days; percentile 52.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization. Patches Fixed in 3.0.367.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mf22-92pm-m8p8
- Revision 1 · created ·
Published from osv record GHSA-mf22-92pm-m8p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24709 Advisory: Cross site scripting in @awsui/components-react IDs: CVE-2022-24709, GHSA-mf22-92pm-m8p8 Record: https://patchnext.com/advisories/cve-2022-24709 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @awsui/components-react 3.0.367. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @awsui/components-react: affected < 3.0.367; fixed in 3.0.367 ## Suggested inspection (read-only) - `npm ls @awsui/components-react --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @awsui/components-react. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mf22-92pm-m8p8 (OSV record GHSA-mf22-92pm-m8p8 lists affected ranges: npm @awsui/components-react >=0 <3.0.367 (fixed)) - Verified: https://github.com/advisories/GHSA-mf22-92pm-m8p8 (GitHub-reviewed advisory GHSA-mf22-92pm-m8p8 lists affected ranges: npm @awsui/components-react >=0 <3.0.367) Commands are suggestions: review each one before running it.
Loading voting…