HashiCorp Nomad Artifact Download Race Condition
CVE-2022-24686GHSA-gwmc-6795-qghj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/nomad 1.2.6, 1.1.12, 1.0.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.3.0, < 1.0.18>= 1.1.0, < 1.1.12>= 1.2.0, < 1.2.6
- Fixed in
- 1.2.6, 1.0.18, 1.1.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gwmc-6795-qghj lists affected ranges: Go github.com/hashicorp/nomad >=0.3.0 =1.1.0 =1.2.0 <1.2.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2022-24686: 0.86% estimated exploitation activity in the next 30 days; percentile 58.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Nomad and Nomad Enterprise 0.3.0 through 1.0.17, 1.1.11, and 1.2.5 artifact download functionality has a race condition such that the Nomad client agent could download the wrong artifact into the wrong destination. This issue is fixed in 1.0.18, 1.1.12, and 1.2.6.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gwmc-6795-qghj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24686 Advisory: HashiCorp Nomad Artifact Download Race Condition IDs: CVE-2022-24686, GHSA-gwmc-6795-qghj Record: https://patchnext.com/advisories/cve-2022-24686 (revision 1, source checked 26 Oct 2026, 14:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/nomad 1.2.6, 1.1.12, 1.0.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/nomad: affected >= 0.3.0, < 1.0.18; >= 1.1.0, < 1.1.12; >= 1.2.0, < 1.2.6; fixed in 1.2.6, 1.0.18, 1.1.12 ## Suggested inspection (read-only) - Go github.com/hashicorp/nomad: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/nomad. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gwmc-6795-qghj (GitHub-reviewed advisory GHSA-gwmc-6795-qghj lists affected ranges: Go github.com/hashicorp/nomad >=0.3.0 =1.1.0 =1.2.0 <1.2.6) Commands are suggestions: review each one before running it.
Loading voting…