Incorrect Authorization in NATS nats-server
CVE-2022-24450GHSA-g6w6-r76c-28j7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/nats-io/nats-streaming-server 0.24.1; github.com/nats-io/nats-server/v2 2.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/nats-io/nats-streaming-server
- Affected
- >= 0.15.0, < 0.24.1
- Fixed in
- 0.24.1
Go github.com/nats-io/nats-server/v2
- Affected
- >= 2.0.0, < 2.7.2
- Fixed in
- 2.7.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g6w6-r76c-28j7 lists affected ranges: Go github.com/nats-io/nats-streaming-server >=0.15.0 =2.0.0 <2.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-24450: 1.33% estimated exploitation activity in the next 30 days; percentile 71.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
(This advisory is canonically <https://advisories.nats.io/CVE/CVE-2022-24450.txt) Problem Description NATS nats-server through 2022-02-04 has Incorrect Access Control, with unchecked ability for clients to authorize into any account, because of a coding error in a long-extant experimental feature. A client crafting the initial protocol-level handshake could, with valid credentials for any account, specify a target account and switch into it immediately. This includes any other tenant, and includes the System account which controls nats-server core operations. For deployments not using multi-tenancy through NATS Accounts, there is still a vulnerability: normal users are able to choose to be in the System account. An experimental feature to provide dynamically provisioned sandbox accounts was designed to allow a server administrator to turn on an option to allow clients to dynamically request a brand new account inline at connection time. This feature went nowhere, but lived on in the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g6w6-r76c-28j7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24450 Advisory: Incorrect Authorization in NATS nats-server IDs: CVE-2022-24450, GHSA-g6w6-r76c-28j7 Record: https://patchnext.com/advisories/cve-2022-24450 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/nats-io/nats-streaming-server 0.24.1; github.com/nats-io/nats-server/v2 2.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/nats-io/nats-streaming-server: affected >= 0.15.0, < 0.24.1; fixed in 0.24.1 - Go github.com/nats-io/nats-server/v2: affected >= 2.0.0, < 2.7.2; fixed in 2.7.2 ## Suggested inspection (read-only) - Go github.com/nats-io/nats-streaming-server: check the installed version with your package manager. - Go github.com/nats-io/nats-server/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/nats-io/nats-streaming-server, github.com/nats-io/nats-server/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g6w6-r76c-28j7 (GitHub-reviewed advisory GHSA-g6w6-r76c-28j7 lists affected ranges: Go github.com/nats-io/nats-streaming-server >=0.15.0 =2.0.0 <2.7.2) Commands are suggestions: review each one before running it.
Loading voting…