Skip to content

← Actionable
High, CVSS 8.6amended

Code injection via SVG file in convert-svg-core

CVE-2022-24429GHSA-54px-mhwv-5v8x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (convert-svg-core 0.6.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
EPSS
  • CVE-2022-24429: 0.91% estimated exploitation activity in the next 30 days; percentile 60.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package convert-svg-core before 0.6.3 are vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-54px-mhwv-5v8x

  2. Revision 1 · created ·

    Published from osv record GHSA-54px-mhwv-5v8x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-24429

Advisory: Code injection via SVG file in convert-svg-core
IDs: CVE-2022-24429, GHSA-54px-mhwv-5v8x
Record: https://patchnext.com/advisories/cve-2022-24429 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: convert-svg-core 0.6.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm convert-svg-core: affected < 0.6.3; fixed in 0.6.3

## Suggested inspection (read-only)
- `npm ls convert-svg-core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on convert-svg-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-54px-mhwv-5v8x (OSV record GHSA-54px-mhwv-5v8x lists affected ranges: npm convert-svg-core >=0 <0.6.3 (fixed))
- Verified: https://github.com/advisories/GHSA-54px-mhwv-5v8x (GitHub-reviewed advisory GHSA-54px-mhwv-5v8x lists affected ranges: npm convert-svg-core >=0 <0.6.3)

Commands are suggestions: review each one before running it.

Loading voting…