Insufficient validation when decoding a Socket.IO packet
CVE-2022-2421GHSA-qm95-pgcg-qqfq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (socket.io-parser 4.2.1, 4.0.5, 3.4.2, 3.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm socket.io-parser
- Affected
- >= 4.1.0, < 4.2.1>= 4.0.0, < 4.0.5< 3.3.3>= 3.4.0, < 3.4.2
- Fixed in
- 4.2.1, 3.3.3, 3.4.2, 4.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qm95-pgcg-qqfq lists affected ranges: npm socket.io-parser >=4.0.0 =4.1.0 =0 =3.4.0 <3.4.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qm95-pgcg-qqfq lists affected ranges: npm socket.io-parser >=4.1.0 =4.0.0 =0 =3.4.0 <3.4.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-2421: 1.43% estimated exploitation activity in the next 30 days; percentile 73.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Due to improper type validation in the socket.io-parser library (which is used by the socket.io and socket.io-client packages to encode and decode Socket.IO packets), it is possible to overwrite the placeholder object which allows an attacker to place references to functions at arbitrary places in the resulting query object. Example: This bubbles up in the socket.io package: :warning: IMPORTANT NOTE :warning: You need to make sure that the payload that you received from the client is actually a Buffer object: If that's already the case, then you are not impacted by this issue, and there is no way an attacker could make your server crash (or escalate privileges, ...). Example of values that could be sent by a malicious user: - a number that is out of bounds Sample packet: 451-["hello",{"placeholder":true,"num":10}] - a value that is not a number, like undefined Sample packet: 451-["hello",{"placeholder":true,"num":undefined}] - a string that is part of the prototype of Array, like…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qm95-pgcg-qqfq
- Revision 1 · created ·
Published from osv record GHSA-qm95-pgcg-qqfq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2421 Advisory: Insufficient validation when decoding a Socket.IO packet IDs: CVE-2022-2421, GHSA-qm95-pgcg-qqfq Record: https://patchnext.com/advisories/cve-2022-2421 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: socket.io-parser 4.2.1, 4.0.5, 3.4.2, 3.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm socket.io-parser: affected >= 4.1.0, < 4.2.1; >= 4.0.0, < 4.0.5; < 3.3.3; >= 3.4.0, < 3.4.2; fixed in 4.2.1, 3.3.3, 3.4.2, 4.0.5 ## Suggested inspection (read-only) - `npm ls socket.io-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on socket.io-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qm95-pgcg-qqfq (OSV record GHSA-qm95-pgcg-qqfq lists affected ranges: npm socket.io-parser >=4.0.0 =4.1.0 =0 =3.4.0 <3.4.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qm95-pgcg-qqfq (GitHub-reviewed advisory GHSA-qm95-pgcg-qqfq lists affected ranges: npm socket.io-parser >=4.1.0 =4.0.0 =0 =3.4.0 <3.4.2) Commands are suggestions: review each one before running it.
Loading voting…