Magento improper input validation vulnerability
CVE-2022-24086GHSA-f8fv-f786-9933
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (magento/community-edition 2.4.3-p2, 2.3.7-p3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.3.3-p1, < 2.3.7-p3>= 2.4.0, < 2.4.3-p2
- Fixed in
- 2.4.3-p2, 2.3.7-p3
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2022-24086 to the Known Exploited Vulnerabilities catalog on 2022-02-15.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2022-02-15).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f8fv-f786-9933 lists affected ranges: Packagist magento/community-edition >=2.3.3-p1 =2.4.0 <2.4.3-p2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:H
- EPSS
- CVE-2022-24086: 99.20% estimated exploitation activity in the next 30 days; percentile 99.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f8fv-f786-9933
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-24086 Advisory: Magento improper input validation vulnerability IDs: CVE-2022-24086, GHSA-f8fv-f786-9933 Record: https://patchnext.com/advisories/cve-2022-24086 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: magento/community-edition 2.4.3-p2, 2.3.7-p3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/community-edition: affected >= 2.3.3-p1, < 2.3.7-p3; >= 2.4.0, < 2.4.3-p2; fixed in 2.4.3-p2, 2.3.7-p3 ## Suggested inspection (read-only) - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2022-24086 to the Known Exploited Vulnerabilities catalog on 2022-02-15.) - Verified: https://github.com/advisories/GHSA-f8fv-f786-9933 (GitHub-reviewed advisory GHSA-f8fv-f786-9933 lists affected ranges: Packagist magento/community-edition >=2.3.3-p1 =2.4.0 <2.4.3-p2) Commands are suggestions: review each one before running it.
Loading voting…