Improper Neutralization of Special Elements used in a Command ('Command Injection') in Weblate
CVE-2022-23915GHSA-3872-f48p-pxqj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (weblate 4.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI weblate
- Affected
- < 4.11.1
- Fixed in
- 4.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3872-f48p-pxqj lists affected ranges: PyPI weblate >=0 <4.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2022-23915: 3.10% estimated exploitation activity in the next 30 days; percentile 87.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Weblate didn't correctly sanitize some arguments passed to Git and Mercurial, which allowed changing their behavior in an unintended way.
Patches The issues were fixed in the 4.11.1 release. The following commits are addressing it: * 35d59f1f040541c358cece0a8d4a63183ca919b8 * d83672a3e7415da1490334e2c9431e5da1966842
Workarounds Instances in which untrusted users cannot create new components are not affected.
References * SNYK-PYTHON-WEBLATE-2414088
For more information If you have any questions or comments about this advisory: * Open a topic in discussions * Email us at care@weblate.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3872-f48p-pxqj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23915
Advisory: Improper Neutralization of Special Elements used in a Command ('Command Injection') in Weblate
IDs: CVE-2022-23915, GHSA-3872-f48p-pxqj
Record: https://patchnext.com/advisories/cve-2022-23915 (revision 2, source checked 25 Oct 2026, 00:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: weblate 4.11.1. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI weblate: affected < 4.11.1; fixed in 4.11.1
## Suggested inspection (read-only)
- `python -m pip show weblate`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on weblate.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3872-f48p-pxqj (OSV record GHSA-3872-f48p-pxqj lists affected ranges: PyPI weblate >=0 <4.11.1 (fixed))
Commands are suggestions: review each one before running it.Loading voting…