aws-iam-authenticator allow-listed IAM identity may be able to modify their username, escalate privileges before v0.5.9
CVE-2022-2385GHSA-pp3f-98qg-5g75
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sigs.k8s.io/aws-iam-authenticator 0.5.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go sigs.k8s.io/aws-iam-authenticator
- Affected
- < 0.5.9
- Fixed in
- 0.5.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pp3f-98qg-5g75 lists affected ranges: Go sigs.k8s.io/aws-iam-authenticator >=0 <0.5.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2022-2385: 1.10% estimated exploitation activity in the next 30 days; percentile 65.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security issue was discovered in aws-iam-authenticator where an allow-listed IAM identity may be able to modify their username and escalate privileges.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pp3f-98qg-5g75
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-2385 Advisory: aws-iam-authenticator allow-listed IAM identity may be able to modify their username, escalate privileges before v0.5.9 IDs: CVE-2022-2385, GHSA-pp3f-98qg-5g75 Record: https://patchnext.com/advisories/cve-2022-2385 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sigs.k8s.io/aws-iam-authenticator 0.5.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Go sigs.k8s.io/aws-iam-authenticator: affected < 0.5.9; fixed in 0.5.9 ## Suggested inspection (read-only) - Go sigs.k8s.io/aws-iam-authenticator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sigs.k8s.io/aws-iam-authenticator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pp3f-98qg-5g75 (GitHub-reviewed advisory GHSA-pp3f-98qg-5g75 lists affected ranges: Go sigs.k8s.io/aws-iam-authenticator >=0 <0.5.9) Commands are suggestions: review each one before running it.
Loading voting…