Command injection in Alluxio
CVE-2022-23848GHSA-j3ch-vjph-8q6v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.alluxio:alluxio-core-common 2.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.alluxio:alluxio-core-common
- Affected
- < 2.7.3
- Fixed in
- 2.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3ch-vjph-8q6v lists affected ranges: Maven org.alluxio:alluxio-core-common >=0 <2.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-23848: 1.21% estimated exploitation activity in the next 30 days; percentile 68.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Alluxio before 2.7.3, the logserver does not validate the input stream. NOTE: this is not the same as the CVE-2021-44228 Log4j vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3ch-vjph-8q6v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23848 Advisory: Command injection in Alluxio IDs: CVE-2022-23848, GHSA-j3ch-vjph-8q6v Record: https://patchnext.com/advisories/cve-2022-23848 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.alluxio:alluxio-core-common 2.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.alluxio:alluxio-core-common: affected < 2.7.3; fixed in 2.7.3 ## Suggested inspection (read-only) - Maven org.alluxio:alluxio-core-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.alluxio:alluxio-core-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3ch-vjph-8q6v (GitHub-reviewed advisory GHSA-j3ch-vjph-8q6v lists affected ranges: Maven org.alluxio:alluxio-core-common >=0 <2.7.3) Commands are suggestions: review each one before running it.
Loading voting…