Embedded Malicious Code in node-ipc
CVE-2022-23812GHSA-97m3-w2cp-4xx6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-ipc 10.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-ipc
- Affected
- >= 10.1.1, < 10.1.3
- Fixed in
- 10.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-97m3-w2cp-4xx6 lists affected ranges: npm node-ipc >=10.1.1 <10.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-97m3-w2cp-4xx6 lists affected ranges: npm node-ipc >=10.1.1 <10.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-23812: 4.23% estimated exploitation activity in the next 30 days; percentile 91.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The package node-ipc versions 10.1.1 and 10.1.2 are vulnerable to embedded malicious code that was introduced by the maintainer. The malicious code was intended to overwrite arbitrary files dependent upon the geo-location of the user IP address. The maintainer removed the malicious code in version 10.1.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-97m3-w2cp-4xx6
- Revision 1 · created ·
Published from osv record GHSA-97m3-w2cp-4xx6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23812 Advisory: Embedded Malicious Code in node-ipc IDs: CVE-2022-23812, GHSA-97m3-w2cp-4xx6 Record: https://patchnext.com/advisories/cve-2022-23812 (revision 2, source checked 26 Oct 2026, 12:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-ipc 10.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-ipc: affected >= 10.1.1, < 10.1.3; fixed in 10.1.3 ## Suggested inspection (read-only) - `npm ls node-ipc --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-ipc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-97m3-w2cp-4xx6 (OSV record GHSA-97m3-w2cp-4xx6 lists affected ranges: npm node-ipc >=10.1.1 <10.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-97m3-w2cp-4xx6 (GitHub-reviewed advisory GHSA-97m3-w2cp-4xx6 lists affected ranges: npm node-ipc >=10.1.1 <10.1.3) Commands are suggestions: review each one before running it.
Loading voting…