Improper Authentication in phpmyadmin
CVE-2022-23807GHSA-8wf2-3ggj-78q9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmyadmin/phpmyadmin 5.1.2, 4.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmyadmin/phpmyadmin
- Affected
- >= 4.9.0, < 4.9.8>= 5.1.0, < 5.1.2
- Fixed in
- 4.9.8, 5.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wf2-3ggj-78q9 lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.9.0 =5.1.0 <5.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2022-23807: 0.74% estimated exploitation activity in the next 30 days; percentile 54.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in phpMyAdmin 4.9 before 4.9.8 and 5.1 before 5.1.2. A valid user who is already authenticated to phpMyAdmin can manipulate their account to bypass two-factor authentication for future login instances.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wf2-3ggj-78q9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23807 Advisory: Improper Authentication in phpmyadmin IDs: CVE-2022-23807, GHSA-8wf2-3ggj-78q9 Record: https://patchnext.com/advisories/cve-2022-23807 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmyadmin/phpmyadmin 5.1.2, 4.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmyadmin/phpmyadmin: affected >= 4.9.0, < 4.9.8; >= 5.1.0, < 5.1.2; fixed in 4.9.8, 5.1.2 ## Suggested inspection (read-only) - Packagist phpmyadmin/phpmyadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmyadmin/phpmyadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8wf2-3ggj-78q9 (GitHub-reviewed advisory GHSA-8wf2-3ggj-78q9 lists affected ranges: Packagist phpmyadmin/phpmyadmin >=4.9.0 =5.1.0 <5.1.2) Commands are suggestions: review each one before running it.
Loading voting…