Skip to content

← Actionable
Medium, CVSS 5.7amended

B2 Command Line Tool TOCTOU application key disclosure

CVE-2022-23653GHSA-8wr4-2wm6-w3pr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (b2 3.2.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI b2

    Affected
    < 3.2.1
    Fixed in
    3.2.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.7 · CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2022-23653: 0.21% estimated exploitation activity in the next 30 days; percentile 11.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Linux and Mac releases of the B2 command-line tool version 3.2.0 and below contain a key disclosure vulnerability that, in certain conditions, can be exploited by local attackers through a time-of-check-time-of-use (TOCTOU) race condition. The command line tool saves API keys (and bucket name-to-id mapping) in a local database file ($XDGCONFIGHOME/b2/accountinfo, ~/.b2accountinfo or a user-defined path) when b2 authorize-account is first run. This happens regardless of whether a valid key is provided or not. When first created, the file is world readable and is (typically a few milliseconds) later altered to be private to the user. If the directory is readable by a local attacker and the user did not yet run b2 authorize-account then during the brief period between file creation and permission modification, a local attacker can race to open the file and maintain a handle to it. This allows the local attacker to read the contents after the file after the sensitive information…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-8wr4-2wm6-w3pr

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-8wr4-2wm6-w3pr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-23653

Advisory: B2 Command Line Tool TOCTOU application key disclosure
IDs: CVE-2022-23653, GHSA-8wr4-2wm6-w3pr
Record: https://patchnext.com/advisories/cve-2022-23653 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: b2 3.2.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI b2: affected < 3.2.1; fixed in 3.2.1

## Suggested inspection (read-only)
- `python -m pip show b2`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on b2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8wr4-2wm6-w3pr (OSV record GHSA-8wr4-2wm6-w3pr lists affected ranges: PyPI b2 >=0 <3.2.1 (fixed))
- Verified: https://github.com/advisories/GHSA-8wr4-2wm6-w3pr (GitHub-reviewed advisory GHSA-8wr4-2wm6-w3pr lists affected ranges: PyPI b2 >=0 <3.2.1)

Commands are suggestions: review each one before running it.

Loading voting…