Use of Hard-coded Cryptographic Key in Netmaker
CVE-2022-23650GHSA-86f3-hf24-76q4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/gravitl/netmaker 0.9.4, 0.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/gravitl/netmaker
- Affected
- < 0.8.5>= 0.9.0, < 0.9.4
- Fixed in
- 0.8.5, 0.9.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-86f3-hf24-76q4 lists affected ranges: Go github.com/gravitl/netmaker >=0 =0.9.0 <0.9.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-23650: 1.59% estimated exploitation activity in the next 30 days; percentile 75.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a hard-coded cryptographic key in the code base which can be exploited to run admin commands on a remote server, if you know the address and username of the admin. This effects the server (netmaker) component, and not clients. Patches This has been patched in Netmaker v0.8.5, v0.9.4, and v0.10.0. If you are running these versions, the fix is to perform the following: 1. docker-compose down 2. docker pull gravitl/netmaker:( version ) 3. docker-compose up -d Additional Information If you are running any other version, you will need to upgrade to one of these three versions. If you have a special circumstance that requires running a different version, let us know and we may be able to build a custom patch. For more information If you have any questions or comments about this advisory: Email us at info@gravitl.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-86f3-hf24-76q4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-23650 Advisory: Use of Hard-coded Cryptographic Key in Netmaker IDs: CVE-2022-23650, GHSA-86f3-hf24-76q4 Record: https://patchnext.com/advisories/cve-2022-23650 (revision 1, source checked 26 Oct 2026, 15:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/gravitl/netmaker 0.9.4, 0.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/gravitl/netmaker: affected < 0.8.5; >= 0.9.0, < 0.9.4; fixed in 0.8.5, 0.9.4 ## Suggested inspection (read-only) - Go github.com/gravitl/netmaker: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/gravitl/netmaker. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-86f3-hf24-76q4 (GitHub-reviewed advisory GHSA-86f3-hf24-76q4 lists affected ranges: Go github.com/gravitl/netmaker >=0 =0.9.0 <0.9.4) Commands are suggestions: review each one before running it.
Loading voting…